Software Requirements

RevolutionPHR is accessible using most Internet browsers running on the majority of mobile, laptop or desktop devices.

Supported Internet browsers include:

  • Internet Explorer 7 (or higher)
  • Firefox 3 (or higher)
  • Safari 5 (or higher)
  • Chrome (latest version)

Most Internet browsers provide the opportunity to update through a preferences or help page. For proper behavior of RevolutionPHR, browsers must have both JavaScript and cookies enabled.